The Lupus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter #1
Hiya,
Some of you might remember I had a dose of rituximab recently - irritatingly it doesn't seem to have worked. I felt great after it, but I think that might have had a lot to do with the high steroid dose you get at the same time. I've been having random aches for the past couple of weeks, which I just ignored, and then my wrists and finger joints decided to start protesting... It's not bad yet (I think my kidneys are doing well at the mo, and I have a good pain threshold), just really really annoying that it hasn't worked. The only drug I'm yet to try properly is cyclo, and I don't want to go there (only 26, no kids etc etc). Boo hiss.

Sorry for moaning! :hehe:
 

·
Banned
Joined
·
808 Posts
Hey there, I know just what you mean, I can't remember when you had the rituximab, if it is of any help I clearly remember thinking grr this isn't working and then it started to work, I think it was a good six months after treatment before I got the feeling I was getting the full benefit I think. I hope that it will start to feel like its working soon, and that you feel benefits. It's a bummer when the effects of the steroids wear of isn't it! Best of luck xx
 

·
Administrator
Joined
·
10,179 Posts
Hi Fairy,

The first time I had Rituxan it took 4 months from the second dose for me to start noticing any difference. With subsequent infusions I have responded sooner. There is still hope for you.

Take care,
Lazylegs
 

·
Registered
Joined
·
360 Posts
I don't have personal experience with rituximab but I frequent the Arthritis Insight forum and have read there that it takes time for it to build and subsequent doses will be more effective. Hang in there.
 

·
Registered
Joined
·
217 Posts
Discussion Starter #6
Thankyou! That makes me feel better, I'll keep my fingers crossed (or I would if I could bend them :lol:)
 
1 - 6 of 6 Posts
Top