The Lupus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,289 Posts
Discussion Starter #1
Hi folks,

As some of you may know I seem to be flaring a bit right now. I did a urine test at home this morning and it showed traces of blood, protein and white blood cells.

Every time I've had my urine tested by a doctor it has shown blood but we've always put that down to it being around the time of my period. This time it's not. Only twice have I shown protein which was sent for further analysis with no further investigation.

Now I'm a bit worried as I've been googling! I didn't realise that you could have a problem with the kidneys with no symptoms whatsoever.

I am seeing my doctor tomorrow and will take a sample for him to test. Has anyone else had a similar result which turned out to be nothing?

Any advice is greatly appreciated.

Hugz,

Pam xxx
 

·
Registered
Joined
·
4,444 Posts
Well, I would say yes it's possible to have these things show up without it being indicative of a serious problem. The trace WBC in your urine probably has little to do with lupus at least - the other two are possibly related. Your results could also be just one time offs... or could be due to the start of a presently unsymptomatic UTI.

Trace amounts are generally not too concerning - unless they persist for a long time. Also, first thing in the AM urine is more likely to have some protein in particular. I would try testing again later in the day or evening and see how it turns out. Hopefully it will be reassuring.

Good luck at the doctor appointment tomorrow.
 

·
Registered
Joined
·
1,289 Posts
Discussion Starter #3
Update

My results came back fine which I'm happy about but still a little confused. I really thought that blood, protein & white blood cells would be cause for concern.

Oh well who am I to argue.

Hugz,

Pam xxx
 
1 - 3 of 3 Posts
Top